Overview
When you receive an error, failure, or exception, the logs can potentially describe the erratic behavior by showing one or more error codes. Hereinbelow you will find information related to how the logs should be backed up and where to find them.
Diagnosis
This guide can be applied in the following scenario(s):
- When you receive an Error or Unhandled Exception and you want to troubleshoot the issue to understand the root cause.
- When a Support Agent requests you attach the logs to a Ticket based on a problem reported.
Solution
Prerequisites
- Having access to the Device's software.
A log file is a file that records either events that occur in an application while it runs. Logging is the act of keeping a log. In the simplest case, messages are written to a single log file. They are essential to understand the activities of complex systems, particularly in the case of applications with user interaction.
Mobilogy uses basically 2 types of logs: UME and INFRA logs. These log files can be found in the following paths:
- Application-level logging
- Infrastructure level logging
Application-level logging - UME (Desktop)
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In the Run window (Win + R), type %appdata% and press Enter.
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From the AppData folder, go to Cellebrite Mobile Synchronization > Cellebrite Desktop > Logs folder.
Backup all the files inside this folder.
Application-level logging - UME (Touch 2)
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In the Run window (Win + R), type %appdata% and press Enter.
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From the AppData folder, go to Cellebrite Mobile Synchronization > Cellebrite Touch > Logs folder.
Backup all the files inside this folder.
Another way to save the logs automatically on a Touch 2 device can be found in the Obtaining Application Logs on the Touch 2 Device KB Article
Infrastructure level logging - INFRA (All Platforms)
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In the Run window (Win + R), type %appdata% and press Enter.
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From the AppData folder, go to Cellebrite Mobile Synchronization > Cellebrite Infrastructure > Logs
Backup all the files inside this folder.
Testing
An example of the UME log content is shown in the following picture:
Once you find where the logs are, they can be backed up using a regular USB pen drive.
Related Articles
- Increasing the Logging Level for Log files
- Uninstalling a Corrupted Installation of Mobilogy Software
- Mobilogy Universal Application Freezes When Transferring Videos or Pictures