Overview
Sometimes, when you change the entries of a list in the MGR Graphical User Interface and save it, the change disappears when you reconnect.
This article describes the possible resolutions for this issue.
Root Cause
The issue may be caused due to the following reasons:
- Delay in synchronizing the change
- Multiple users updating at the same time
- Wrong MGR behavior
Process
The following list states the possible resolutions for this issue that must be applied in the listed order.
-
To check if the issue is caused by an unusual delay in synchronizing the changes on the MGR GUI (because of which the changes are not being reflected), navigate to Settings > Pending Transactions in the MGR GUI and check the Saving and Syncing options. If they are not empty, wait until all of them are processed. If the view is empty, proceed to the next step.
-
Check if multiple users are working at the same time, as this could result in a situation when more than one operation is being performed simultaneously. This could be an issue in the case of changes on lists, routing rules, etc. where there are dependent tables. If only a single user is working at a time, proceed to the next step.
-
Restart the MGR by running the following commands as a root user.
Note: Keep a note of the output of steps 1 and 4 as they may be required for further troubleshooting if the issue remains unresolved.
systemctl status mgr
systemctl stop mgr
systemctl start mgr
systemctl status mgr
If you have trouble running the
systemctl
commands, please restart the MGR process by running the following commands as a root user:/usr/TextPass/bin/tp_mgr_stop
/usr/TextPass/bin/tp_mgr_start
Note: If the issue persists after restarting the MGR, file a support request in the Skyvera Support Portal and share details of all the steps followed and the saved output of the commands.