Overview
How to fix crashes / powering on issues or inoperative app/devices so you can perform data transfer.
Diagnosis
- Device powers on but the system will crash and need to be restarted.
- You cannot access the app through the app icon on Windows Desktop. Main menu does not load, or opens up but does not respond, or screen flickers.
- Device won't power on when charging cable is unplugged.
- When there is a corrupted installation of Mobilogy software.
Solution
Prerequisites
- Having access to the device's Software.
- Having access to the device's Hardware
In this section, we will be explaining the different cases that you can find when trying to upgrade or update your device.
Case 1: Mobilogy Now: System Requirements
- This should be the starting point in the troubleshooting phase. The Mobilogy Software needs to meet specific hardware components and other software resources to work efficiently on a computer. This article serves as a guideline and defines the minimum and recommended system requirements (prerequisites) for the Mobilogy Now software. For more information, please take a look at the Mobilogy Now: System Requirements KB article.
Case 2: Uninstalling a Corrupted Installation of Mobilogy Software
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There are cases where you may need to uninstall your Mobilogy software. Here are some examples:
- You installed the wrong version of Mobilogy software
- While installing, there was a failure on the Mobilogy software
- Mobilogy icon is deleted - it does not exist on the desktop anymore
- Mobilogy app shortcut link is broken - App doesn't open after clicking on the Mobilogy icon
This article provides information on the advantages of using external tools for uninstallation, and it details how to uninstall the Mobilogy software by using CCleaner. For more information, check the Uninstalling a Corrupted Installation of Mobilogy Software KB article.
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Right after finishing the Uninstall process, you can Download the latest version of Software for Manual Installation and then Install the software.
Case 3: Recovery Process for Touch Devices
- If your device is dead (no longer powers up), and none of the above steps helps you to solve the problem, The Mobilogy Touch devices built-in recovery feature provides users with the ability to quickly recover their operating system (OS) back to the factory default settings. For more information, please take a look at the Recovery Process for Touch Devices KB article.
Case 4: Mobilogy Software for Desktop HUB Not Loading After An Update
- The Desktop/Universal software might stop loading after a recent update or installation. This issue usually occurs when Windows restarts after a new installation. This article provides information on how to resolve this problem. For more information, please take a look at the Mobilogy Software for Desktop HUB Not Loading After An Update.
Case 5: Desktop HUB Driver Installation for Windows 10
- This article provides step-by-step instructions on how to install/update the HUB driver to resolve device recognition issues. A common symptom for this issue is when you run the application, select Backup (Or Transfer) and connect a device to the Source USB port, the device fails to be detected. For more information, check the Desktop HUB Driver Installation for Windows 10 KB article.
Testing
Once you apply this article, the device should power up and start regularly. You should be prompted with the initial screen, as shown in this picture:
(Bear in mind that the screen might change based on the device you are using)