Overview
In this article, you will find the correct version of the Remote Tool (TeamViewer) if you don't know what version should be installed.
Diagnosis
- When the current TeamViewer version fails and has to be replaced with a fresh new installation.
- When a Customer Support agent requires a remote connection but he states that cannot accomplish the task because your TeamViewer version is not the correct version.
Solution
Prerequisites
- As this is not mandatory, we recommend navigating through the link that will be shared later on this KB article from the affected device.
TeamViewer facilitates remote connections to the Mobilogy devices. We know you might be busy when you report an issue with the device, and it is very likely you cannot stay long on the phone while troubleshooting.
For those cases, we offer the option to troubleshoot issues remotely. Your intervention may be needed depending on the issue, and you will be informed in such cases.
- The Mobilogy devices have a Windows Embedded version, and TeamViewer is installed as part of the OS image.
- With TeamViewer 13 (this is the version currently supported by Central Support) you can enable unattended access, which is useful when you restart the device or get someone else to connect to the device.
- TeamViewer 13 has the option to send key combinations for when you need to run a command or use Ctrl + F4 to forcefully close the software (For cases when the X button does not respond).
- Teamviewer Quick Support has also applications for iPhone and Android devices, in case we need to troubleshoot something directly into the phone.
Note
The exact version used by Central Support is v13.2.36218. If you are running a different version, please uninstall it and download Windows Version (v13.2.36218) from these sources:
- External (download.teamviewer.com) Link
- Internal (support.skyvera.com) Link
Testing
To confirm that you downloaded the proper version from the link provided above, please follow these steps:
- Locate the path where the file was saved.
- Right-click on the file and go to properties, as shown below:
- Go to the Details tab and confirm the version downloaded is 13.2.36218.0 as shown in the below picture:
Once you download and install the version v13.2.36218, you can provide the Customer Support agent with the ID and password, as shown below, so that the agent can connect to your device.
Important
Keep in mind that the agent may not be immediately available when you share the ID and the password. You should schedule a session with the agent using the Calendly link agent shared or let the agent know when you will be available for a session.