Overview
There may be cases when a user is assigned to a new role and the solution restrictions are not working. The user may be able to access a solution that they should not or may not be able to access a solution that they should.
Diagnosis
In order to check if everything is properly configured, follow these steps:
- Log in to the User Manager.
- Locate the affected user by filling the filtering fields.
- Check the role that is assigned to them. If it is correct, move to the Solution Restriction tab. Check that the solution list is correct for the assigned role:
Solution
According to the diagnosis, you may have the following outcomes:
- The role assigned to the user is wrong: In this case, click the Edit button in the same row and change it to the correct one.
- The list of solutions the role has access to is wrong: If this is the case, click the Edit button in the same row as the role in the Solution Restriction tab and allow or deny access to the solutions accordingly. Be aware that this change will affect all users that are assigned this role.
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The role assigned to the user and the list of solutions the role has access to are both correct: If the configuration has been just changed, you may need to wait a few minutes before it takes effect. If it has been a long time since the configuration has changed and it is not working, create a support ticket specifying:
- The user name
- The role they are assigned to
- The solution you expect it to have the access allowed or denied
- When the last configuration change has occurred. If it was a long time ago, just provide an estimate (it has not been changed in the last weeks or months).
Testing
After the fix has been applied, the user must have access only to the correct solutions. Remember that the change can take a few minutes to take effect. Wait a while before checking again.