Overview
When looking at the Solution Overview report and filtering by hierarchy, it is possible that some unknown or pending validation items appear. This article explains why this happens and what can be done about it.
Diagnosis
In order to check if the issue is happening, follow these steps:
- Log in to the eManager.
- Open the Solution Overview report (in most cases, this report is loaded by default).
- In the left pane, open the Solutions filter and select a solution.
- Open a hierarchy filter. If there are any Unknown or Pending Validation items under it, select them.
- Check if the Responses column shows a number greater than zero.
When the issue exists it is due to a missing hierarchy node. Each invitation can have references for up to three hierarchies. Each hierarchy can be an employee, a store, a region, etc. If an invitation references a hierarchy node that does not exist, it is considered as a pending validation. After a period of time, if the hierarchy is not fixed, it is set to unknown.
Solution
When the invitation has a pending validation, this can be fixed by importing the missing hierarchy. The records will be updated and the reports will reflect it accordingly. In order to know how to fix errors in invitation files, check Why are invitation files being rejected by the import process?.
For the invitations whose hierarchy has already been set to unknown, it is not possible to change it.
Testing
To check if the issue has been fixed, open the report again. There should be no invitations in pending validation anymore.