Overview
While trying to send a file to a device, the file gets unpacked at the wrong path location. This article serves as a guide on how to update the path through the database.
Environment
All versions of Service Gateway lower than 5.1 (to be released)
Root Cause
TargetFileName was hardcoded as an empty value, this is the only way to change its value.
Resolution
1. Login into the database.
2. Perform the query below:
UPDATE sprt_ec_file SET target_file_name='<value>' WHERE filename = '<filename>';
Confirmation
Send the command again to the device to check if the file was delivered at the right destination.