Article Original Creation Date: 2011-01-12
Problem
Policy stuck in status below:
GOING_TO_STOPPED.
Environment
- Solaris 10,
- SG 4.0.9.0
- JBoss 4.0.4.GA
- Tomcat 5.25
- Oracle 10
Root Cause
There are several thousands of devices in the sprt_sg_policy_device_hold table queued for that particular policy.
Somehow the policy status change was stuck by that.
Resolution
NOTE: This can be done on a running system.
- *Run the following query to figure out the sg_policy_guid of the involved policy:
Select count(sg_policy_guid),sg_policy_guid FROM sprt_sg_policy_device_hold WHERE add_method='QUEUED' group by sg_policy_guid;
Pick the right policy guide out of the result list, check it in the sprt_sg_policy table for the right policy name/description. - Run the following delete command: this guide is an example:
DELETE FROM sprt_sg_policy_device_hold WHERE add_method='QUEUED' AND sg_policy_guid='c07e7747-0834-11e0-af94-db0813351ddb';
- *Change the status from the policy if it still exists in the GOING_TO_STOPPED state directly in the sprt_sg_policy table via:
Update sprt_sg_policy set status='STOPPED' where status='GOING_TO_STOPPED';
- *Via the GUI> Policy> involved policy check the status tab of that policy and if needed Unapprove it.