Article Original Creation Date: 2014-08-28
Problem
Attempting to login to Shop Floor Manager Mobile for the first time results in one of two errors:
Authentication failed
Incorrect username or password
Environment
SFMM, IIS, Aptean Service Gateway, ASG
Root Cause
Aptean Service Gateway SQL scripts have not been run against company and M2MSystem database containers.
This assumes:
- The username and password attempting to be used have been verified as working correctly in M2M (case and length of password keyed both work in M2M).
- Utuser triggers are not missing from the UTIL VFP database causing login credentials to be excluded from m2msystem..utuser and the message of incorrect login thus valid.
- The ASG Configurator has been run again to verify the connection to SQL Server.
- Browsers (desktop only) have been refreshed with browsing history deleted
This is extremely important and to rule it out, you may want to try a browser you don't typically use like Chrome or Firefox. You must shut the browser and re-launch after clearing history.
Solution
To resolve logins failing with Authentication or Invalid messages on the first login:
- On the SQL Server, navigate to C:\inetpub\wwwroot\ApteanServiceGateway\SQLScripts directory
- Double click the ServiceGatewayCompanyDBScript.sql script file
- SQL Management Studio will open with the script in the Query Window - make sure to Execute this against each live company to use SFMM
- Repeat the same process for the ServiceGatewaySystemDBScript.sql, making sure that the M2MSystem database container is the active DB before executing in Management Studio
- Relaunch SFMM and attempt to log in.