Article Original Creation Date: 2010-08-19
Problem
A significant number of INFORM events are not being logged to the SPRT_NC_CWMP_SESSION database table.
Environment
ServiceGateway 4.0.10.0
Solaris 10
Weblogic 8.1 MP2
Oracle 10g
Root Cause
CWMP session logging is enabled.
Solution
Addressed in ServiceGateway 4.2.3.
EE 23289 - CWMP logging content is being lost
When CWMP Logging is turned on, there was the potential for log data to be lost if the
transfer of a batch of logs failed for any reason. Also, there was no limit to the size of a
batch, and large batches could lead to a failure.
When CWMP Logging is turned on, there was the potential for log data to be lost if the
transfer of a batch of logs failed for any reason. Also, there was no limit to the size of a
batch, and large batches could lead to a failure.
A batch of CWMP Logging information is now sent in smaller chunks, the size specified in
ACS.properties. Additionally, it is sent over JMS using a separate thread within the ACS to
avoid impacting the time between status updates. The asynchronous nature of JMS means
that the thread does not need to wait for the data to be committed to the database. Also,
if there is a failure during the transfer, the data is not discarded but will be sent when the
JMS connection resumes.