Article Original Creation Date: 2014-02-03
Overview
The WebLogic managed server hangs, for no apparent reason, when trying to start the Service Gateway application.
#### <> <> <> <1391081260147> Channel Weight 50
Accept Backlog 50
Login Timeout 5000ms
Max Message Size 10000000
Message Timeout 60s
Idle Timeout 65s
Tunneling Timeout 40s
Tunneling Ping 45s>
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#### <> <> <> <1391081260302>
#### <> <> <> <1391081260314>
#### <> <> <> <1391081260679>
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Environment
WebLogic 9/10
Root Cause
WebLogic performs a security initialization AFTER the IIOP configuration is complete. During this security initialization, WebLogic initializes LDAP. It is likely that the LDAP configuration files, located in the /servicegateway/weblogic-domain/servers//data/ldap/ldapfiles folder have become corrupt.
Resolution
Remove (or rename) the 'ldapfiles' folder and restart the managed server instance to rebuild the LDAP configuration files from scratch. This will enable WebLogic to complete the security initialization and the managed server should then continue through the normal startup process.