Article Original Creation Date: 2014-10-24
Overview
After updating ServiceGateway to 4.4.1, the following error prevents Activation Policy to register a new CPE (Customer Premise Equipment).
2014-10-13 10:53:17,792 ERROR servicegateway.policy - class: PolicyExecutionManager method: executePolicies: 10046 - Error executing policy (name=Default Activation): EJB Exception: ; nested exception is: net.sf.ehcache.CacheException: Could not fetch object for cache entry with key "d8fdbf05-9cf9-11dc-8374-79a95a63e51d"
2014-10-13 10:53:17,798 ERROR servicegateway.policy - class: PolicyExecutionManager method: executePolicies: 10046 - Error executing policy (name=Default Boot): EJB Exception: ; nested exception is: net.sf.ehcache.CacheException: Could not fetch object for cache entry with key "debd71a4-65a5-11de-a4b3-1b324f6c7b99".
2014-10-13 10:53:17,800 ERROR encore.system - class: com.supportsoft.encore.common.dao.DaoHelper method: determineDatabaseType(): 00068 - Unsupported database type: Unknown - could not obtain connection: Transaction BEA1-031E57A545CE4D852707 not active anymore. tx status = Marked rollback. [Reason=weblogic.transaction.internal.AppSetRollbackOnlyException: setRollbackOnly called on transaction]
Environment
- WL 10.3 MP5
- Solaris 10
- Oracle 10g
- ServiceGateway (SG) 4.4.1
Root Cause
For some reason the first Default policy = Default Activation is damaged by the upgrade process. It is also Influencing other Default policies, and thus no device gets activated.
Resolution
To solve the issue mentioned previously, follow the steps listed below:
- Rename or delete the Default Activation policy.
- Rebuild a new Default Activation policy, save it and approve it.
Confirmation
After implementing the solution detailed, all the default activation policies will be effective without any error.