Article Original Creation Date: 2010-05-27
Overview
This issue is replicated by the customer's scenario below:
After installing ServiceGateway as a non-root user a user is not able to deploy any additional ear files without first restarting the WebLogic administration server process as the root user.
A summary of details provided by the user is as follows.
- Completed a ServiceGateway 4.0 installation as a non-root user.
- Initial installation ServiceGatey version 4.0.7.0.
- Patched to ServiceGateway version 4.0.9.0.
- All installations/patches performed using the ServiceGateway automated installer.
- Unable to deploy the ServiceGateway database migration tool ear in the environment.
- This ear, and in fact no ear, will deploy unless the WebLogic administration server process is restarted as the root user.
- The non-root user owns the BEA (/usr/local/bea) and SPRT (/usr/local/sprt) directories and everything beneath them.
- The installer and application log files contain no details related to the problem.
- The following messages are displayed in the WebLogic console when attempting to deploy the ear file manually (screenshot attached).
Unable to access the selected application
Exception in AppMerge flows' progression
Environment
- ServiceGateway 4.0.9.0
- Solaris 10
- Weblogic 9.2 MP1
- Oracle 10g
Root Cause
Incorrect ownership permission settings on the following files.
/var/tmp/appcgen_sprt-600-ServiceGatewayMigration4.0.6.1.039-wl92.ear
/var/tmp/appmergegen/sprt-600-ServiceGatewayMigration4.0.6.1.039-wl92.ear
Solution
Correct the ownership permission issues on the noted files.
chown /var/tmp/appcgen_sprt-600-ServiceGatewayMigration4.0.6.1.039-wl92.ear
chown /var/tmp/appmergegen/sprt-600-ServiceGatewayMigration4.0.6.1.039-wl92.ear