Article Original Creation Date: 2010-03-17
Overview
While applying the latest patch to ServiceGateway (SG), the following error is logged in installer.log:
Update_DB-JBoss.pl' (UPDATE_DB_JBOSS): Success=false
Environment
- Solaris / Windows 2003 Server
- ServiceGateway 4.x
Root Cause
The root cause of the error is the change in database identifier after installing the application and not updating the patch install causing it to point to the old database identifier.
Resolution
The Database Identifier, UserName, and Password are stored in the file /usr/local/sprt//sprt_install.dat on the server.
If any of the parameters mentioned above are changed after the application is installed, update the values in sprt_install.dat accordingly.