Article Original Creation Date: 2010-05-17
Problem
Sometimes customers might see that few records/devices in their ServiceGateway (SG) database are deleted automatically. They cannot find these devices in the SG Database any longer.
Environment
Solaris
Oracle
Root Cause
There is a Script in SG 4.0 which deletes records in ServiceGateway if that particular device has not contacted ServiceGateway in predefined time (Default is 90 days).
This settings of this script can be accessed in the SG GUI at the below path
Administration -> Settings -> Preferences -> Record Purging
Solution
In the above path, the Inactive Device Expiration age can be increased to a higher value (Please note that these values are in Seconds) if the customer needs this script to wait longer before purging the inactive devices.
Or the entire script can be disabled by unchecking the Age Devices check box.