Article Original Creation Date: 2012-05-15
Overview
Following error message displays while executing a report from ServiceGateway GUI:
The report has returned too many rows. Check the Parameters and try again.
Environment
- Solaris
- Oracle
- SQL Server
Root Cause
The root cause of the error is the number of rows, the report returns, is higher than the configured value.
Resolution
- Navigate to Administration > Settings > Preferences
-
From the left sidebar, Select General and in the right section, find the setting Maximum Number of Rows in a Report. The default value for this field is 1000. Increase the value as desired.
Note: Prefer keeping the Maximum Number of Rows in a Report value to a lesser value, as running reports generating a large number of rows affects application/database performance.