Article Original Creation Date: 2013-11-19
Overview
In the sprt_sg_policy
table, after trying to manually change the STATUS, ADMINISTRATIVE_STATUS and CSV_CONTENTS columns to be able to delete policies that stay forever in the Going to be stopped state or Building from Active state, policy defintions and policy logging cannot be opened. Moreover, the following exceptions are returned in the server.log:
Environment
Root Cause
The entries for the STATUS and ADMINISTRATIVE_STATUS columns were mixed up causing non-existing entries in these columns, causing the exceptions.
Resolution
This is the right steps to take when trying to delete these policies out of the Policy definitions screen:
- Change directly in the DB table
sprt_sg_policy
the STATUS to STOPPED. - Change directly in the DB table
sprt_sg_policy
the ADMINISTRATIVE_STATUS to DISABLED. - Delete all csv entries out of the sprt_sg_policy.csv_contents.
- Commit these changes.
- Clear the browser cache on all 3 app-servers.
- Change the policy status in the GUI from STOPPED to PENDING via the Unapprove button.
- Delete the policy in the GUI.
sprt_sg_policy
table, but changing the STATUS and ADMINISTRATIVE_STATUS columns with the right values would also have solved it.