Article Original Creation Date: 2012-02-23
Overview
In SG Version 4.1.1, when a timer driven policy is executed with a CSV list as filter, the status counters for the policy does not show the correct sum.
For example:
I have a job with 42 devices in the CSV list and looking in policy log before start shows 42 remaining. After the job is executed counters shows:
- Success Count: 24 (77.4%)
- Skipped Count: 5 (16.1%)
- Failure Count: 2 (6,5%)
That gives a total of 31 and status for 11 devices is missing. The percentage is calculated for the remaining data. Data is also not found in the execution log.
Environment
Root Cause
These logs sometimes show a gap every hour of up to 15 minutes.
Information
While investigating the inefficient policy runs, the counts are completely the same between the counters in the policy logging and the counts in the complete logs gathered manually from both application servers.
On the other hand, the counts are not the same when the _Encore.xx.log combined logfiles are used. They do not hold the complete data.