Overview
You might receive errors while installing iTunes or transferring data due to changes in newer versions iTunes. You should install iTunes v12.10.0.7 to eliminate the errors. This is because Mobilogy supports that version of iTunes only.
Diagnosis
This behavior or issue can be observed in the following scenario(s):
- You are trying to install the new version of iTunes in the Touch device but you receive an error.
- You are trying to update the obsolete version of iTunes in the Touch device but you receive an error.
- You already updated to the latest version of iTunes and you are receiving errors while transferring.
- You receive the error "There was a problem downloading the software for the iPhone "iPhone". an unknown error occurred (9006)"
To check the version installed on your system, you might want to access the properties of the main executable by following these steps:
- Open Windows Explorer in Windows 10.
- Navigate to the location where the application is installed. (It should be C:\Program Files\iTunes)
- Locate the main executable ("iTunes.exe").
- Right-click on it and then select Properties.
- In the Properties window, go to the Details tab.
There you will find information about the product name, the product version and so on.
iTunes must not be modified, neither a new version should be installed nor and old version should be updated manually. Unfortunately, we stopped giving support over iTunes feature, since Apple made changes to their code that restricts the access to third-party software, as stated in the App Store Review Guidelines. More information can be found here.
Solution
Prerequisites
- Having access to the device's Software.
If you already updated the iTunes version to the latest version, you will need to uninstall iTunes from your system, restart the device and install the 12.10.0.7 version that can be found in this link.
If you need help on how to install iTunes, please check the Install iTunes on a Windows Environment article.
If you need help on how to uninstall iTunes, you can use CCleaner to uninstall iTunes. To do so, you can also follow the guidelines marked on the Uninstalling a Corrupted Installation of Mobilogy Software KB Article.
Update
If you recovered a device and the iTunes version is different (generally Higher) than 12.10.0.7, the reason is that you have a Touch 2 device which base image was updated recently. We've added the version 12.7.1.14 to the new base Windows images, as it works flawlessly.
If you recover to factory defaults a device and the Out of the Box (OOTB) version of iTunes is version 12.7.1.14, it will work fine. However, the same logic applies; you shall not update the version manually, but wait for the UPs to update the version if needed.
Testing
Once you confirm you have installed the proper version of iTunes, you should not get any error while transferring.
Take into consideration that the version installed must be the 12.10.0.7
If you still get errors while trying to make a transfer, execute the recovery procedure, and then download the latest version of the software and install it in your system.
Related articles
- Unable to transfer an encrypted iOS device on Mobilogy Desktop
- Unable to Transfer from iPhone 11 or IOS 13 Devices
- Install iTunes on a Windows Environment